← Înapoi la Urmăritori

Cel mai recent articol

Ultima verificare

Urmăritori 0 urmăritori
Articole: 143
  1. Below I describe how to generate an OpenPGP key and import its subkeys to a FST-01G device running Gnuk.

  2. Installing Gnuk on FST-01G running NeuG

    The FST-01G device that you order from the FSF shop runs NeuG.

  3. OpenPGP 2019 Key Transition Statement

    I have created a new OpenPGP key and will be transitioning away from my old key.

  4. Planning for a new OpenPGP key

    I’m the process of migrating to a new OpenPGP key.

  5. Vikings D16 server first impressions

    I have bought a 1U server to use as a virtualization platform to host my personal online services (mail, web, DNS, nextCloud, Icinga, Munin etc).

  6. I installed Debian 9.0 “Stretch” on my Lenovo X201 laptop today.

  7. GPS on Replicant 6

    I use Replicant on my main Samsung S3 mobile phone.

  8. I have used non-standard RSA key size for maybe 15 years.

  9. Let’s Encrypt Clients

    As many others, I have been following the launch of Let’s Encrypt.

  10. I have been using Replicant on the Samsung SIII I9300 for over two years.

  11. Combining Dnsmasq and Unbound

    For my home office network I have been using Dnsmasq for some time.

  12. Back in early 2012 I had been helping with system administration of a number of Debian/Ubuntu-based machines, and the odd Solaris machine, for a couple of years at $DAYJOB.

  13. SSH Host Certificates with YubiKey NEO

    If you manage a bunch of server machines, you will undoubtedly have run into the following OpenSSH question: The authenticity of host 'host.example.org (1.2.3.4)' can't be established.

  14. Scrypt in IETF

    Colin Percival and I have worked on an internet-draft on scrypt for some time.

  15. Certificates for XMPP/Jabber

    I am revamping my XMPP server and I’ve written down notes on how to set up certificates to enable TLS.

  16. Laptop decision fatigue

    I admit defeat.

  17. Laptop indecision

    I wrote last month about buying a new laptop and I still haven’t made a decision.

  18. EdDSA and Ed25519 goes to IETF

    After meeting Niels Möller at FOSDEM and learning about his Ed25519 implementation in GNU Nettle, I started working on a simple-to-implement description of Ed25519.

  19. Laptop Buying Advice?

    My current Lenovo X201 laptop has been with me for over four years.

  20. Replicant 4.2 0003 on I9300

    The Replicant project released version 4.2 0003 recently.

  21. OpenPGP Smartcards and GNOME

    The combination of GnuPG and a OpenPGP smartcard has been implemented and working for almost a decade.

  22. Dice Random Numbers

    Generating data with entropy, or random number generation (RNG), is a well-known difficult problem.

  23. After I moved to a new OpenPGP key (see key transition statement) I have received comments about the short life length of my new key.

  24. Wifi on S3 with Replicant

    I’m using Replicant on my main phone.

  25. Replicant 4.2 0002 and NFC on I9300

    I’m using Replicant on my Samsung SIII (i9300) phone (see my earlier posts).

  26. I have moved to a new OpenPGP key.

  27. OpenPGP Key Transition Statement

    I have created a new OpenPGP key 54265e8c and will be transitioning away from my old key.

  28. I’m in the process of moving to a new OpenPGP key, and I want to include a small JPEG image of myself in it.

  29. Replicant 4.2 on Samsung S3

    Since November 2013 I have been using Replicant on my Samsung S3 as an alternative OS.

  30. Necrotizing Fasciitis

    Dear World, On the morning of December 24th I felt an unusual pain in my left hand between the thumb and forefinger.

  31. Replicant 4.0 on Samsung Galaxy S III

    For the last half-year I have used CyanogenMod on an Nexus 4 as my main phone.

  32. As a maintainer of several software packages I often find myself copying text snippets from the README file into different places (savannah, github, freecode, emails, etc).

  33. For the past weeks I have been working on implementing RFC 6030, also known as Portable Symmetric Key Container (PSKC).

  34. Using OATH Toolkit with Dropbox

    Today there was an announcement that Dropbox supports two-factor authentication.

  35. Small syslog server

    My home network has several devices that do not have large persistent storage to keep log files.

  36. Unattended SSH with Smartcard

    I have several backup servers that run the excellent rsnapshot software, which uses Secure Shell (SSH) for remote access.

  37. The ability to connect a 3G modem to a wireless router to form a Internet connected ad-hoc network of machines is very powerful.

  38. Introducing the OATH Toolkit

    I am happy to announce a project that I have been working quietly on for about a year: the OATH Toolkit.

  39. On Password Hashing and RFC 6070

    The RFC Editor has announced a new document, RFC 6070, with test vectors for PKCS5 PBKDF2.

  40. GNU SASL with SCRAM-SHA-1-PLUS

    I have finished the SCRAM implementation in GNU SASL.

  41. Debian on Lenovo X201

    I have acquired a new laptop/netbook, a Lenovo X201.

  42. I have blogged about GNU SASL and GS2-KRB5 with the native Kerberos on Mac OS X before, so the next logical step has been to support GS2-KRB5 on Windows through MIT Kerberos for Windows (KfW).

  43. Bridging SASL and GSS-API: GS2

    Yesterday (12th July 2010) the RFC editor announced the publication of RFC 5801, which I’m co-author of.

  44. OpenWRT 10.03 “Backfire”

    Earlier I have written about OpenWRT configuration for two routers in a home network and OpenWRT configuration for 3G dial-up (which succeeded my summerhouse OpenWRT writeup) before.

  45. GS2-KRB5 in GNU SASL 1.5.0

    I have worked in the IETF on the specification for the next generation GSSAPI-to-SASL bridge called GS2 (see my status page for background) for a couple of years now.

  46. Fellowship interview

    At FSCONS I met Stian Rødven Eide who is doing a series of fellowship interviews for FSF Europe.

  47. Nordic Free Software Award 2009

    Last night at FSCONS I was awarded the Nordic Free Software Award, sharing the price with Daniel Stenberg who incidentally (or perhaps not) I have been collaborating with on some projects.

  48. Storing OpenPGP keys in the DNS

    Many years ago, for my master’s thesis, I worked on evaluating using the DNS to store certificates.

  49. Thread Safe Functions

    I have read Russel Coker’s nice article on identifying use of thread unsafe functions.

  50. CACert and GnuTLS

    I haven’t seen this before, so I thought I’d documment how to generate a server TLS certificate using CACert.