Creează un cont pentru a te abona la acest blog și a-i urmări articolele pe pagina Lectură.
-
I was in Ops for several years at a fairly large SaaS.
-
This means it’s really easy to get stuck.
-
Today I was troubleshooting a problem where my computer could not talk to a host on my network.
-
We sold our 2018 Nissan Leaf last year.
-
At work, if your job is to move a bunch of heavy things from one side of the room to another, you should use whatever assistive tech you have on hand: a wagon, a forklift… even an AI-powered robot.
-
Just have notebooks lying around, or on your person.
-
So, I use this as an excuse to buy beautiful Moleskine, Leuchtturm, and MUJI notebooks and coloured pens, and I stash them in my gym bag.
-
Every post I publish represents at least two things I’ve learned: the thing that prompted me to write the post, and the thing I learned in the course of writing it.
-
This was a helpful reminder to focus on the basics first.
-
Among other things, Fong argues that Costco’s limited selected raises its average product quality.
-
Here’s the thing no one acknowledges about the entrepreneurship narrative: it’s written by survivors.
-
Financial options live in highly liquid markets.
-
When we record every casual encounter, we’re optimizing for “Information Retrieval” at the expense of “Relationship Formation,” treating our friends // colleagues // loved ones as data sourced to be mined, rather than co-conspirators in the brilliantly me…
-
[…] LLM-generated prose undermines a social contract of sorts: absent LLMs, it is presumed that of the reader and the writer, it is the writer that has undertaken the greater intellectual exertion.
-
Emphasis mine: On my first solo two-night camping trip, I forgot to bring a backup battery to charge my laptop or phone.
-
Poor is the person without Slack.
-
I’ve been thinking about doing this exact thing recently.
-
I installed Ubuntu Desktop 26.04 (Resolute Racoon) last week.
-
In my view, the current core AI skill is shifting as much work onto AI agents as possible, without going too far.
-
Give me a blank page of my notebook and my pen — I shall fill that page in no time.
-
Unfuck Your Habitat has a lot of great information for keeping your space tidy.
-
Thanks for Simon Willison for the link. […] Between 2000 and 2024, farmers sold in total a Colorado-sized chunk of land all on their own, 77 times all land on data center property in 2028, and grew more food than ever on what was left.
-
Today my computer ran out of disk space.
-
I’ve been drilling on LeetCode recently and ran into a problem which I did not know how to solve while using constant extra space: Given a non-empty array of integers nums, every element appears twice except for one.
-
Today I spent some time learning about SQL common table expressions (aka “CTEs”).
-
Today, I learned about shell process substitution from Bread on Penguin’s latest video.
-
I’ve been using Sublime Text as my main text editor since August of 2014.
-
Today I needed to create a new SSH public/private keypair for work.
-
Today I encountered an API which sometimes sends back numbers as strings.
-
Rebasing your feature branch on main regularly is a good idea.
-
Here’s how to add key/value pairs to an http.Reqest’s query string in Go: package main import ( "fmt" "net/http" ) func main() { // create a request req, _ := http.NewRequest(http.MethodGet, "http://www.example.com/", nil) // get the current query…
-
Path Note /usr/local/bin/ System-wide binaries go here!
-
I’ve been using Alacritty exclusively for over a year.
-
This interview with Simon Willison is great.
-
There have been four1 major versions of HTTP in-use in the last 30-ish years: Version RFC Year HTTP/1.0 RFC 1945 1996 HTTP/1.1 RFC 2068 1997 HTTP/2 RFC 7540 2015 HTTP/3 RFC 9114 2022 It’s surprising to me how quickly HTTP/1.1 was released after HTTP/1.0.
-
This blog post by Sean Goedecke was a great read on high-level system design patterns.
-
Much productivity advice on the internet is too complicated and not actually that helpful.
-
I get the impression that a lot of people are overwhelmed by their personal email inbox nowadays and get so much email that they’ve more or less given up on it.
-
I regularly have to look up how to create an Echo router context with (a) path parameters and (b) query parameters, so I’m making this post as a cheat sheet for my future self.
-
I ran across a blog post by Josh Bleecher Snyder today which has some beautiful backoff algorithms in Go.
-
Today I needed to remove a bad route on macOS.
-
My work laptop was provisioned with a case-insensitive filesystem for some strange reason.
-
I got bit by this again today, so I’m writing it down so I can reference it later.
-
I was playing around with implementing Depth First Search (DFS) and Breadth First Search (BFS) in Go today.
-
My blog post from yesterday made me think… how can you marshal and unmarshal enums in Go correctly?
-
I was asked yesterday how you implement enums in Go.
-
Getting things ready in advance I’ve been musing on how ridiculously useful it is to get things ready in advance.
-
I’ve been doing a weekly planning session for the last five or so years.
-
This post documents some testing I did around whether unit tests in Golang are run in parallel.
-
Thanks to Julia Evan’s latest post, I learned that creating new slices by sub-slicing an existing slice has an important caveat: They can sometimes use the same backing array!